Author Topic: WCL Can't discover bluetooth devices using Toshiba Stack 7.10.12  (Read 2786 times)

Offline tongt

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Dear sir,

I am using WCL 6.7.6.0 .NET to connect to Toshiba bluetooth stack ver  7.10.12 developed using vs2005. I have tried running the sample BluetoothDiscoveryDemo. I can connect to the bluetooth radio (after pressing the Enum button) and the toshiba bluetooth stack appears. Then i press the "Discovery" button, a dialog "Started" appear and then "Nothing found". I have run this under XP and Win7 and the results are consistent.

The same program and bluetooth dongle works fine using MS BT Stack where it can discover the services.

Would really appreciate it if you could help to look into the problem.

Thanks in advanced.
Tong

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL Can't discover bluetooth devices using Toshiba Stack 7.10.12
« Reply #1 on: May 21, 2010, 10:31:25 AM »
Hello,

We will terst it once again and back to you.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL Can't discover bluetooth devices using Toshiba Stack 7.10.12
« Reply #2 on: May 21, 2010, 10:51:54 AM »
Hello,

Have just downloaded tha stack version and tested WCL with it. All works. Check that Toshiba stack works. Sometimes it can be installed but does not work correctly.

Offline tongt

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Re: WCL Can't discover bluetooth devices using Toshiba Stack 7.10.12
« Reply #3 on: May 23, 2010, 07:12:25 AM »
Hi Mike,

Thanks for your prompt action and reply. I have tried the same scenario again in Windows 7 vs2005 using the same demo. At line 419,  pDevices->Getcount(), the count is always 0. When i removed the toshiba device driver on the same computer. Everything works well.

The toshiba driver is working as I am able to pair and use the paried device via the toshiba bluetooth setting interface.

I am just wondering if i need to install anything else in VS2005 or any settings i might have missed in the bluetooth driver. Or, anything else i should look out for. I would really appreciate it if you could let me know your configuration that work under windows 7. I am willing to setup one configuration almost identical to your so that i can have something working to start with.

Thanks in advanced.

Sincerely,
Tong

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL Can't discover bluetooth devices using Toshiba Stack 7.10.12
« Reply #4 on: May 23, 2010, 10:52:51 AM »
Hi,

I have nothing specialand there is nothing special required. I tested on Win 7 (64 bit) and XP (32 bit) - all works without any problem.

 

Sitemap 1 2 3 4 5 6 7 8 9