Author Topic: Redist problem and SSP  (Read 2773 times)

Offline robple11

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
Redist problem and SSP
« on: June 16, 2010, 06:11:15 PM »
Hi,

I have two questions:

1) Does the framework support Secure Simple Pairing or is there a plan to support it?

2) I am having a problem deploying my application to a PC running XP Tablet edition, i keep getting an error "File not found exception" before any of my code is run. The HRESULT is 80070002.
Any ideas?

Thanks.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3055
  • Karma: 1000
    • Soft Service Company
Re: Redist problem and SSP
« Reply #1 on: June 16, 2010, 07:15:15 PM »
Hi,

1. It depends on driver. If Bluetooth driver supports it - then WCL does too.
2. Please, take a look on this forum topic: http://forum.btframework.com/index.php/topic,905.0.html

Offline robple11

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
Re: Redist problem and SSP
« Reply #2 on: June 17, 2010, 06:25:21 AM »
Is there a function call to do SSP or does it just happen when trying to pair?

I included all the files mentioned in the forum topic from your link, but i still get the same error. The vcredist_x86.exe is installed as well. It just doesnt make any sense.

The error as displayed on screen:

"System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)"

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3055
  • Karma: 1000
    • Soft Service Company
Re: Redist problem and SSP
« Reply #3 on: June 17, 2010, 07:02:29 AM »
There is no special function for SSP, just call Pair.

This is not WCL error. I can guess that you didn't redist dlls.

Offline robple11

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
Re: Redist problem and SSP
« Reply #4 on: June 17, 2010, 10:10:50 AM »
All the dll's are included in the setup. I know the setup is fine because i have installed it on other XP machines and it worked fine.
The exception occurs before "Form1.cs" is executed, pretty much before the application even starts.

Nothing seems to be missing but it still has the exception. I tried installing the WCL source as well but that didnt even work.

Its a little UMPC samsung touch screen device, with an embedded broadcom bluetooth device, using windows stack and running Windows Tablet PC edition.

It still doesnt make any sense to me.
Any other ideas?

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3055
  • Karma: 1000
    • Soft Service Company
Re: Redist problem and SSP
« Reply #5 on: June 17, 2010, 10:27:58 AM »
Unfortunately I have no ideas. As it works on othe PC then it has all it needs. So the issue is on your tabled pc.

If you don't mind you can send your setup to me and I check it on our pcs then. May be find the problem.

Offline robple11

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
Re: Redist problem and SSP
« Reply #6 on: June 18, 2010, 05:04:01 AM »
Found the problem, issue was due to target machine having XP SP2 while development machine was SP3. As soon as i updated to latest SP3 it worked fine.

Thanks for the help.

 

Sitemap 1 2 3 4 5 6 7 8 9