Author Topic: Chinese Blacberry and WCLAutheticator  (Read 4074 times)

Offline fabiorov

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
Chinese Blacberry and WCLAutheticator
« on: January 18, 2011, 08:53:37 PM »
Hi,

My app has WclAAUthenticator to handle pin code asking, and that work the most of times, but with chinese blackberry I input (in the BB) the same PIN code of the wclauthenticator, but it doesn't connect, the only way to connect is using the microsoft original bluethoot utility included in WIndows and using pin code for the transfer. isn't the wclauthenticator is designed for handle this?

Antother question I tested my app in a shopping mall were there is a large number of mobile phones and the wclproximity tries only once to send me files, the rest it get "ignored" result.... but If I try to send it the file with the windows utility It works great... why?

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3055
  • Karma: 1000
    • Soft Service Company
Re: Chinese Blacberry and WCLAutheticator
« Reply #1 on: January 18, 2011, 09:40:29 PM »
Hi,

1. It may happen with some devices. We have no solution for that.
2. Because you selected just 1 fone but Sender sends to a few at time.

Offline fabiorov

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
Re: Chinese Blacberry and WCLAutheticator
« Reply #2 on: January 18, 2011, 09:57:34 PM »
Ok, in point 2 (when I have large number of mobile phones) what can I do for fix that?.. because my app doesn't work well in that situation, I just try to send the file once... but If I have few phones it works great

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3055
  • Karma: 1000
    • Soft Service Company
Re: Chinese Blacberry and WCLAutheticator
« Reply #3 on: January 18, 2011, 09:58:42 PM »
Set maximum connection to 2 or 3. What WCL edition do you use?

Offline fabiorov

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
Re: Chinese Blacberry and WCLAutheticator
« Reply #4 on: January 18, 2011, 10:06:41 PM »
I use 6.8.1.0 for .NET (registered), I'll try to reduce the simultaneous connections... but I don't like it, isn't the dongle designed for them? I use SENA UD100 dongle with microsoft stack or do I must to use anothe dongle (again with 2 or 3 connections) to increase simultaneous connections?

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3055
  • Karma: 1000
    • Soft Service Company
Re: Chinese Blacberry and WCLAutheticator
« Reply #5 on: January 18, 2011, 10:12:43 PM »
There are lot of things may cause the problem you have got. Dongle, Driver, USB Bus. But we will check and I'll back to you tomorow with our tests results.

Offline fabiorov

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
Re: Chinese Blacberry and WCLAutheticator
« Reply #6 on: January 18, 2011, 10:25:44 PM »
Thamks, I'll be waiting, you have an excellent customer service

Offline fabiorov

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
Re: Chinese Blacberry and WCLAutheticator
« Reply #7 on: January 18, 2011, 11:23:56 PM »
Mike, while you do the test, can you tell me if the "secure" property can be edited in run time, or do I have to stop the proximity sender, chamge it and start it again? Can I edit individual conection with the secure property? for example... if my dongle supports 7 connections, can 3 of them be secure and the rest unsecure?

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3055
  • Karma: 1000
    • Soft Service Company
Re: Chinese Blacberry and WCLAutheticator
« Reply #8 on: January 18, 2011, 11:25:11 PM »
Can be changed in runtime (when sending is in progress).
Unfortunately no but I may think on it : send me an e-mail with reminder to mike@btframework.com so I can discuss it with my team and we may try to add something like that

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3055
  • Karma: 1000
    • Soft Service Company
Re: Chinese Blacberry and WCLAutheticator
« Reply #9 on: January 19, 2011, 02:00:08 PM »
Hi
We were testing the WCL with regards to the issue reported. It appears as we reproduced the problem but the problem looks like hardware related. However that was just fast testing and we continue testing it. I wil update you when get news.

Offline fabiorov

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
Re: Chinese Blacberry and WCLAutheticator
« Reply #10 on: January 19, 2011, 07:10:58 PM »
Ok, I'll be waiting, help me with that please

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3055
  • Karma: 1000
    • Soft Service Company
Re: Chinese Blacberry and WCLAutheticator
« Reply #11 on: January 24, 2011, 11:09:31 AM »
Hi,

we done the tests and found that with some hardware it may cause the issue. Unfortunately we have no the solution right now but will work on it.

 

Sitemap 1 2 3 4 5 6 7 8 9