Author Topic: Pairing returns authentication failed error, but device is paired  (Read 2635 times)

Offline Jov

  • Newbie
  • *
  • Posts: 20
  • Karma: 0
Hi Mike,

I am having problems with pairing. When I call the Pair() method, it fails with WCL_E_AUTHENTICATION_FAILED and the call takes a long time after I have entered the code on the phone. Although the error is returned, the pairing is actually successful.

I have to do:

Code: [Select]
bool paired = false;
dev->GetPaired(*pRadio, paired);
if (paired) {
onStatusChanged (L"Already paired.");
return true;
}

int error = dev->Pair(*pRadio, pin);
if (error != WCL_E_SUCCESS)
{
// verify that it indeed failed?
dev->GetPaired(*pRadio, paired);
if (paired) {
      onStatusChanged (L"Pairing succeeded anyway.");
return true;
}

// return error
wclShowError(error);
onError (L"Pairing failed.");

return false;
}

The main problem I am having is that the pair call takes a long time. Although as soon as I have entered the PIN on the phone, a refresh on BluetoothDiscoveryDemo shows me the device is paired...

This is with an 4 yrs or so old laptop with BT 2.0 (I have given you the drivers earlier).

Any suggestions welcome!

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3052
  • Karma: 1000
    • Soft Service Company
Re: Pairing returns authentication failed error, but device is paired
« Reply #1 on: October 25, 2012, 06:29:57 PM »
Hi,

What BT drivers do you use and what OS?

Offline Jov

  • Newbie
  • *
  • Posts: 20
  • Karma: 0
Re: Pairing returns authentication failed error, but device is paired
« Reply #2 on: November 13, 2012, 06:39:18 PM »
Hi Mike,

sorry for the long delays.

Rhe driver is http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=be&prodTypeId=321957&prodSeriesId=3357377&prodNameId=3357378&swEnvOID=1093&swLang=13&mode=2&taskId=135&swItem=ob-57457-1 . The laptop is a HP 6910p.

I haven't installed this to see if this matches what is on my system but a version of this software is definitely installed. The driver date on the "Bluetooth Bus Enumerator" device is 20/11/2007 and the driver version is 5.1.0.4601. The "HP Integrated Module with Bluetooth 2.0 Wireless Technology" device is from 3/12/2007 and has driver version 5.1.0.4800.

In the meantime I decided to drop attempting to get this to work and installed a broadcom BT 4.0 dongle and replaced the drivers.

The OS is WinXP Service Pack 3

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3052
  • Karma: 1000
    • Soft Service Company
Re: Pairing returns authentication failed error, but device is paired
« Reply #3 on: November 13, 2012, 06:45:25 PM »
Hi,

Thank you for the information. I will install it and try to reproduce.

Offline Jov

  • Newbie
  • *
  • Posts: 20
  • Karma: 0
Re: Pairing returns authentication failed error, but device is paired
« Reply #4 on: November 13, 2012, 07:37:50 PM »
Thank you!

 

Sitemap 1 2 3 4 5 6 7 8 9