Author Topic: GSMmodem  (Read 2311 times)

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
GSMmodem
« on: April 05, 2013, 10:51:58 PM »
Hi,

you add new communication to the last version wclGSMModem.

I try to run on my two mobile phone Samsung GT-I9300 and Nokia Lumia 920.

the demo File GSMModemClient and get Error.

 "Internal driver error".   My system XP and  Bluetooth BlueSoleil 10.0.417.0. VS 2005.

the HandsFreeDemo is working.

what this new communication. and what phone support.

anther problem on windows 8 with  Bluetooth BlueSoleil 10.0.417.0. and VS 2012.

the  HandsFreeDemo not working i get error.

 "Internal driver error".

Best regards,




Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: GSMmodem
« Reply #1 on: April 05, 2013, 11:56:16 PM »
Hi,

With thouse devices you have to check Use Hands Free Service in GSMDemo. Also you must pair phones before connect.

Unfortunately we didn't test BS 10 on Win 8 completly yet but as reported on BS support forum BS 10 has lot of problems when runs on Win 8.

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
Re: GSMmodem
« Reply #2 on: April 06, 2013, 12:17:18 AM »
hi,

i check all three possibility I get the same error on HandFreeClient  demo it working. and the phone are pair.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: GSMmodem
« Reply #3 on: April 06, 2013, 01:13:45 AM »
HandsFreeClient uses absolutely different way to communicate with device and will be removed (combined with GSMModem) in next version.

However, I have just tested Win 8 with BS 10. I used Nokia lumia 710 and BlackBerry cells. Both work fine (BlackBerry works with DUN and HFP, Lumia only with HFP as doesn't have DUN).

The reasons to get Internal Driver Error (or Timout):

1. Device is not paired
2. Device is runed off or in "sleep" mode (for BT 4)
3. Dongle is in sleep mode (for BT 4) or turned off
4. Something wrong with dongle: try to switch it off and then on again.

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
Re: GSMmodem
« Reply #4 on: June 15, 2013, 07:45:28 AM »
Hi

I install the new Ver 6.11.9.0
I test the wclGSMModem with my mobile phone Samsung GT-I9300
the Call,Hang Up is working but the Answer not working keep ring.
with my Nokia C7 All of the options work.
what mobile phone support SMS.
Samsung GT-I9300,Nokia Lumia 920,Nokia C7 not support.
how can I disconnect the audio connection when  disconnect the HandsFree.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: GSMmodem
« Reply #5 on: June 15, 2013, 07:55:55 AM »
Hi,

Answering call with Samsung is known problemn and we are working on it.
SMS is supported only over AT commands so any mobile which supports SMS sending with AT commands is supported. WinPhone, WinMobile, Android, iPhone, Symbian do not support SMS over AT commands.
There is no way to disconect audio connection for HandsFree as it is required.

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
Re: GSMmodem
« Reply #6 on: June 15, 2013, 09:01:47 AM »
Hi

with  HandsFree protocol . the Answer  is working on Samsung  .

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: GSMmodem
« Reply #7 on: June 15, 2013, 09:47:05 AM »
Ok, thanks.

 

Sitemap 1 2 3 4 5 6 7 8 9