Author Topic: No Data coming in.  (Read 8755 times)

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
No Data coming in.
« on: May 17, 2013, 07:44:39 PM »
Hi

I had two  Widcomm 5.0.1.801 and BlueSoleil 10.0.417.0. Dongles on my computer.
I decided to remove the Widcomm Dongle. But now I have a problem- no data coming in. The connection is alright, but there are no triggers for wclClient_OnData. For example, when i'm using the VirtualPort demo and discovering my devices and choosing GPS reciever, creating a port, then connecting I get a "Connected" message but no data is coming in. This problem also happen in other demos when i'm using SPP communication. With the Widcomm Dongle it worked.

Best Regards.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: No Data coming in.
« Reply #1 on: May 17, 2013, 08:32:46 PM »
Hi

As I could understand you use BlueSoleil driver on your computer now. If so try to reinstall driver (also make sure that there is only one dongle). Probably the drivers were mixed.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: No Data coming in.
« Reply #2 on: May 17, 2013, 08:47:32 PM »
By the way, what OS do you use? Also do you use 32 or 64 bit WCL?

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
Re: No Data coming in.
« Reply #3 on: May 17, 2013, 08:58:41 PM »
Hi

I have One  BlueSoleil Dongle and I order from than. I try to reinstall more then one.
If I using old BlueSoleil ver like 2.4. I can connect with BlueSoleil manager to my GPS reciever and get Data in the new ver not working.
did WCL API working on old BlueSoleil Ver.

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
Re: No Data coming in.
« Reply #4 on: May 17, 2013, 08:59:58 PM »
Hi

I using XP  32Bit.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: No Data coming in.
« Reply #5 on: May 17, 2013, 09:02:30 PM »
Ok, then: Can BlueSoleil connect to your GPS receiver and receive data itself: connect to your GPS from BlueSoleil manager and then try use created COM in Teminal?

P.S: WCL supports BlueSoleil 1.6 and above.

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
Re: No Data coming in.
« Reply #6 on: May 17, 2013, 09:17:35 PM »
Hi

No no data coming in I can see the connection but no data. and with the old ver 2.X it working

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: No Data coming in.
« Reply #7 on: May 17, 2013, 09:21:38 PM »
So it does not work without WCL too? I mean when you use Hyper Terminal or something and BlueSoleil manager (without WCL) it does not work as well?

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
Re: No Data coming in.
« Reply #8 on: May 17, 2013, 09:31:35 PM »
Hi

yes I using Franson GpsGate.

If I looking  on bluetooth serial port(COM7) Status i can see received data but where it is.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: No Data coming in.
« Reply #9 on: May 17, 2013, 09:37:14 PM »
Well, then its something with BlueSoleil driver. Possible: vCOM numeration issue in Windows. You can try to uninstall BlueSoleil, remove all vCOMs from Registry and reset vCOM counter. It may help.

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
Re: No Data coming in.
« Reply #10 on: May 17, 2013, 09:45:20 PM »
Hi

I will try but can you help me where i can find the vCOMs Registry and to reset the counter.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: No Data coming in.
« Reply #11 on: May 17, 2013, 09:47:50 PM »
Unfortunately I do not remember registry keys for vCOMs but I am sure it can be found in internet.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: No Data coming in.
« Reply #12 on: May 17, 2013, 11:11:54 PM »
To reset vCOM counter:

1. Uninstall BlueSoleil.
2. Delete all vCOMs (if your PC has not hardware COM ports you must have no COM ports in device manager)
3. Open RegEdit
4. Find this key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\COM Name Arbiter
5. Set first byte of ComDB param to 00.

Offline printrmd

  • Newbie
  • *
  • Posts: 35
  • Karma: 0
Re: No Data coming in.
« Reply #13 on: May 24, 2013, 11:25:27 AM »
Hi Mike

Sorry took me a week to answer.
I don't know how others managing with BlueSoleil .
when installing BlueSoleil App is creates two Bluetooth Serial Port (COM3,COM4).
when I use the VirtualPort demo and try to create a com i get message from BlueSoleil manager create a COM
and get error message from my App this occur twice. The third time I get the create com.
but we cannot get data. if we check the COMS in the system we have two COM3 two COM4 and one COM5. I need to rename the double COMS but it must be on the correct order if not I need to do all over again.i need to check on the registry file that the com is OK. Now everything works.  "BUT"
If trying to create a com i get message Internal driver error i need to try Number of time to get the created COM.
then it working and get data.

Is there another way I don't believe that people are doing it.

Sorry about the long story



Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: No Data coming in.
« Reply #14 on: May 24, 2013, 11:28:54 AM »
Hi

It is known BlueSoleil bug when it creates identical vCOM ports (vCOMs with identical numbers). Do the steps I posted early to remove all vCOMs from your system and reset vCOMs counter and then it will work correct.

 

Sitemap 1 2 3 4 5 6 7 8 9