Author Topic: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle  (Read 569 times)

Offline bconline

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
Hi, guys.

I've a Parani Sena ud100-g03 usb dongle bluetooth 4.0 and with his software BLE, i discover all my 4.0 ble devices, but with the example "BLEexample" c# demo project, not discover anything, ;(,   why?

This dongle uses Bluesoleil Bluetooth stack and the drivers are correctly installed (so, with his software I can discover all devices)

Thanks in advance.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #1 on: April 24, 2017, 12:04:10 PM »
Hi,

Can you tell me what is your BLE device? Also does WCL show any error message or simple can not find the device?

Offline bconline

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #2 on: April 24, 2017, 12:34:53 PM »
Hi, i'ts a simple keykeeper, WCL tells "nothing found".

In the "bluetooth discover" proyect, the radio is showed, but, i select it and find devices and nothing found too.

When a little USB dongle that uses MS stack, the device founds without problems.

the problem can be in the bluesoleis stack or his dongle?, rare that with his software, the devices appears.

Thanks.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #3 on: April 24, 2017, 02:39:01 PM »
It looks that the device is not BLE but classic if you can find it using MS stack and BluetoothDiscovery project. You have also use BlouetoothDiscovery project with BlueSoleil and make sure that the device is in discoverable mode.

Offline bconline

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #4 on: April 24, 2017, 04:43:55 PM »
No, you not understand me.

The little dongle is a ASUS bt 4.0 dongle, the device is a keysafe keeper (un llavero como decimos in spain) and uses a batery cell rs2032, then is BLE (and it not have discover mode!), however, i've others 2.0 dongles and may NOT detects this device.

The bluetoothdiscovery project enum the RADIO but not found DEVICES. In a few hours i've attach to this topic images in fact to understand me.

My main problem is that this ASUS dongle is short range (less 10 meters) and the parini sena ud100-g03 is 300 meters and for my app, need this range. Asus dongle uses MS Bluetooth stack of win10. Parini sena uses Bluesoleil stack. Attach to te dongle Parini, in the cd software, there are a liitle app that detects BLE devices and discover my little keykepper device, but your library, not.

Sorry my bad english.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #5 on: April 24, 2017, 06:00:20 PM »
Ah, got it now. If it is discovered by BlueSoleil than it should be discovered by WCL as well. So it is probably bug or something in WCL. I will prepare a test application for you tomorrow. The app helps to fix the issue as soon as possible.

Offline bconline

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #6 on: April 25, 2017, 10:08:55 PM »
HI, in this images I explain my problem

This first image is the correctly detection from dongle software



And this other, same dongle, same device, but nothing found too


Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #7 on: April 26, 2017, 10:13:35 AM »
hi,

That is correct the BluetoothDiscovery demo should not find BLE devices. You have to use BLE Demo instead.

Offline bconline

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #8 on: April 26, 2017, 02:01:53 PM »
You have reason, but the BLE project nothing found too, this night i've attach some images.

Thanks.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #9 on: April 26, 2017, 11:28:49 PM »
Please, try the attached test application.

Offline bconline

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #10 on: April 27, 2017, 12:28:53 AM »
Unnafortunely, nothing found BLE.



But, when this app is a compiled app, i've tried from other computer for test and I report you.

Tomorrow I receive other bt 4.0 devices and try it too with this.

You will be wait my notices. Thanks for all at the moment.


Offline bconline

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #11 on: April 27, 2017, 10:22:32 PM »
I've tried with a GIGASET G-TAG and nothing found with your demo project "Bluetooth ble" but i'ts found by bluesoleil discover software.

I'ts rare.... very rare.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #12 on: April 28, 2017, 03:31:49 AM »
Unfortunately I have no such BLE device and can not check it. All BLE devices I have here can be discovered.

Offline bconline

  • Newbie
  • *
  • Posts: 12
  • Karma: 0
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #13 on: April 28, 2017, 08:26:36 AM »
Hi Mike,

Can you recomend me a long-range BLE antenna that's works with your library?, I need about 100-200 meters.

If the solution throught for change the dongle, I change... please, give me some brands and models that sure 100% works with your library and BLE devices.

Thanks.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: WCL BLE don't discover my BLE devices with sena ud100-g03 dongle
« Reply #14 on: April 28, 2017, 08:32:59 AM »
I think it is not a dongle problem. We are reworking code a little bit and I will send you update version soon for test.

 

Sitemap 1 2 3 4 5 6 7 8 9