Author Topic: WCL on Bluesoleil  (Read 5821 times)

sonak

  • Guest
WCL on Bluesoleil
« on: July 30, 2009, 10:08:32 AM »
Hi

I'm evaluating WCL demo applications (especially OPP Client demo) on a PC with a MSI Star Key 2 bluetooth dongle which uses BlueSoleil's driver (Product Version: 2.6.0.8 Stack Version: 06.03.27.20061108). Although everything seems fine on the first run, I mean I'm able to enum radios, select the right one, discover devices, connect to one device, obex connect to the same device, push a file to that device and then disconnect, I can't repeat the aforementioned process again. When I try to connect for a second time, either to the previous device or to another one I get an error message saying "Unable to connect : 2" which seems to be an internal error but I don't understand why. Take in consideration that I've tried this to another PC with the same results. I would like to hear your ideas.

Best regards
Vasilis

Online Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3052
  • Karma: 1000
    • Soft Service Company
Re: WCL on Bluesoleil
« Reply #1 on: July 30, 2009, 10:15:20 AM »
Hi,

First at all try the latest version of WCL. But usualy it is BlueSoleil issue. Try to make longer interval between each connect operation. Or update your bluesoleil drivers.

sonak

  • Guest
Re: WCL on Bluesoleil
« Reply #2 on: July 30, 2009, 11:21:30 AM »
Hi,

I use the latest version of WCL (6.5.11.0). I tried using longer intervals between each connect operation (almost 5 mins) with no success. The result was the same as before after the first successful connection (it was impossible even to start a new device discovery - I always get an error). After exiting application, I has to unplug and replug the dongle in order to become operational again. So I try updating the driver and used the latest provided from IVT (6.4.269.0). This time I was able to connect, disconnect and connect again. The problem was that I couldn't open OBEX connection. It always timed out. I thought that might has to do with the dongle's properties but I can't find something wrong with them.
Any ideas?

Offline sander

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: WCL on Bluesoleil
« Reply #3 on: July 30, 2009, 12:30:52 PM »
Hi,

I don't know if this helps you, but we found that the only stable version of the bluesoleil drivers is 2.3.0.0 Release 060728 (stack version 05.04.11.20060622). We've tried various other revisions, but they all had stability problems (like hanging after the first connection).

Best regards,
Sander

Online Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3052
  • Karma: 1000
    • Soft Service Company
Re: WCL on Bluesoleil
« Reply #4 on: July 30, 2009, 12:31:42 PM »
I have tested it with BS 6.4.240.2. All works perfect. I will download 6.4.269.0 and test it again. Unfortunatly, BlueSoleil drivers has lots of bugs and I can't fix the bugs in BS drivers. May be I'll find some workaround for this issue.

Online Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3052
  • Karma: 1000
    • Soft Service Company
Re: WCL on Bluesoleil
« Reply #5 on: July 30, 2009, 12:32:18 PM »
Hi,

I don't know if this helps you, but we found that the only stable version of the bluesoleil drivers is 2.3.0.0 Release 060728 (stack version 05.04.11.20060622). We've tried various other revisions, but they all had stability problems (like hanging after the first connection).

Best regards,
Sander

The best one I ever used was 1.6 :)

sonak

  • Guest
Re: WCL on Bluesoleil
« Reply #6 on: July 31, 2009, 04:25:37 PM »
Hi,

Mike, I tried 6.4.240.2 without success. It was impossible to OBEX connect. I don't know what to say. Might be the dongle. Unfortunately 2.3.0.0 and 1.6 are not working with the dongle. So I guess I will fall back to MS stack. Anyway, thanks for your help guys.


Best regards,
Vasilis

Offline abw

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Re: WCL on Bluesoleil
« Reply #7 on: July 13, 2010, 08:56:26 PM »
Hi,

I don't know if there any news in this issue but I face with the same problem! After first successful connection the second does not happen :(. I tried with Bluesoleil and with HP intergrated as well, and same result. Do you know any updates?

thnx and
-mfg-
abw

Online Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3052
  • Karma: 1000
    • Soft Service Company
Re: WCL on Bluesoleil
« Reply #8 on: July 14, 2010, 03:53:04 AM »
Hello,

As I already wrote on this forum WCL temporary does not support BS 6.4 as BlueSoleil has changed all internal things and does not allow to connect to any other service except SPP. It is not WCL issue buit BlueSoleil one. we have no workaround for now.

 

Sitemap 1 2 3 4 5 6 7 8 9