Author Topic: A really big problem.  (Read 2027 times)

Cuningan

  • Guest
A really big problem.
« on: November 12, 2009, 08:59:46 PM »
Hello Mike, i have made a new version of me soft, it work fine in me develop computer and in computers where i had not insatalled the old version of me software.

The old version have 6.5.3 WCL version and the new one have the 6.5.9.

The problem come when i try to install the new version in computers where previosly i had the old version, i deinstall the old version of my software and install new.

When i start the application it say that they cant load the wcl.dll file, if a just delete the 6.5.9 and put the 6.5.3 all run perfect.

I try to regsvr32 wcl.dll and didnt solve the problem and i try to regsvr32 /u wcl.dll for unistall old version but i have the same.

I really dont know what to do.

Cuningan

  • Guest
Re: A really big problem.
« Reply #1 on: November 12, 2009, 09:16:57 PM »
Mike, i think that when i install the first soft version the wcl.dll may be registered into windows and when i unistall the soft the old 6.5.3 library continue registered in windows.

How do you make in your demo to unistall the library?

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: A really big problem.
« Reply #2 on: November 12, 2009, 09:25:09 PM »
wcl.dll is not registered. It is not a COM server. I think you miss MFC redist files. This file is located in the Redist folder of WCL installation.

Offline Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: A really big problem.
« Reply #3 on: November 12, 2009, 09:26:01 PM »

 

Sitemap 1 2 3 4 5 6 7 8 9