Author Topic: significant delay on library load  (Read 2143 times)

Offline Veldrin

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
significant delay on library load
« on: March 04, 2010, 09:43:47 AM »
Hi,
I am to buy licenced version of WCL library, but so far I am just testing its demo version.
While using it I noticed significant delay on loading WCL library on application start. Is it connected with demo version and will disappear when I buy licenced one?

Best regards.

Online Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: significant delay on library load
« Reply #1 on: March 04, 2010, 11:05:31 AM »
Hi

There is nothing special in demo version related to library signification. Looks like this issue: http://support.microsoft.com/kb/936344

Offline Veldrin

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
Re: significant delay on library load
« Reply #2 on: March 04, 2010, 11:32:51 AM »
Fix didn't solved the problem.
It takes about 15 seconds after calling wclAPI.Load() for main form to show...
It happens in all demos that ware delivered with WCL library.

Is it normal behaviour?

Online Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: significant delay on library load
« Reply #3 on: March 04, 2010, 11:44:00 AM »
It is not signification issue. Why did you think so? It is normal because when you call Load the library initializes all the drivers and APIs. However, 15 seconds it not OK. It looks like you have had BlueSoleil installed and incorrectly removed. Check your system for btfunc.dll and delete it (if you do not use BlueSoleil drivers).

Offline Veldrin

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
Re: significant delay on library load
« Reply #4 on: March 04, 2010, 11:49:54 AM »
Removal of btfunc.dll help. Thanks.
Can the problem occur again, when some user will use BlueSoleil stack?

BTW
I didn't say it is a significant issue, but significant delay (15 sec is quite a long timie in my opinion) ;)

Online Mike Petrichenko

  • Bluetooth Framework Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 3053
  • Karma: 1000
    • Soft Service Company
Re: significant delay on library load
« Reply #5 on: March 04, 2010, 11:54:50 AM »
I agree, it looks so, but it puts me in wrong way :)

It can appear when use installed and then incorrectly uninstalled BlueSoleil drivers. Unfortunatly there is no workaround to detect such issue. If user uses BlueSoleil - then it does not take too long time and all works good.

 

Sitemap 1 2 3 4 5 6 7 8 9